[fxruby-users] FXRuby compilation error - invalid conversion

Lyle Johnson lyle at knology.net
Thu Mar 31 07:58:16 EST 2005


On Mar 30, 2005, at 8:41 AM, Tom Kwong wrote:

>  Need help.  I can't get FXRuby to compile...
>
>  FXRuby.cpp: In function `void FXRbDestroyAppSensitiveObjects()':
>  FXRuby.cpp:1741: error: invalid conversion from `int (*)(...)' to 
> `int (*)()'
>  FXRuby.cpp:1775: error: invalid conversion from `int (*)(...)' to 
> `int (*)()'
>
>  system = Linux version 2.6.8.1-3-386 (buildd at terranova) (gcc version 
> 3.3.4 (Debian 1:3.3.4-9ubuntu5)) #1 Tue Oct 12 12:41:57 BST 2004
>  ruby = ruby 1.8.2 (2004-08-24) [i386-linux]
>  fox = 1.2.16
>  fxruby = 1.2.5

You're still using one of the preview releases of Ruby 1.8.2; I can 
tell by the date in the version string (2004-08-24). Please upgrade to 
the final release of Ruby 1.8.2, which should report version 
information something like this:

	$ ruby-v
	ruby 1.8.2 (2004-12-25) [powerpc-darwin7.7.0]

Hope this helps,

Lyle




More information about the fxruby-users mailing list