[fxruby-users] FX GUI objects won't display

Lyle Johnson lyle at knology.net
Sun Mar 20 22:49:53 EST 2005


On Mar 20, 2005, at 9:09 PM, Harold Worby wrote:

> Here's my ruby version. Guess I neet to update!
>
> C:\ruby\me>..\bin\ruby -rfox -e 'puts Fox.fxrubyversion'
> 1.0.28
>
> but by directory is named 
> C:\ruby\lib\ruby\gems\1.8\gemsfxruby-1.2.2-mswin32
> what gives?

It looks like you have both FXRuby versions 1.0.28 and 1.2.2 installed. 
That's OK; there's no conflict as far as Ruby's concerned, and it might 
prove useful to have both versions around in case you come across some 
older FXRuby-based application that requires FXRuby version 1.0.x 
instead of 1.2.x.

As you noted, the way to determine your installed FXRuby 1.0 version 
(if any) is to require the 'fox' extension, e.g.

	ruby -rfox -e 'puts Fox.fxrubyversion'

while the way to determine your installed FXRuby 1.2 version (if any) 
is to require 'fox12', e.g.

	ruby -rfox12 -e 'puts Fox.fxrubyversion'

Hope this helps,

Lyle



More information about the fxruby-users mailing list