[fxruby-users] Does anyone have access to an x86-64 box?

lyle at knology.net lyle at knology.net
Mon Mar 14 17:10:19 EST 2005


On Mon, 14 Mar 2005 16:29:07 -0500, Shad Sterling <polyergic at gmail.com> wrote :

> I'm running PLD, and have installed ruby-1.8.2-2.20040906.4.  I looked
> for a ruby-libs package (in poldek; using primarially
> ftp://ftp.amd64.ac.pld-linux.org/dists/ac/PLD/amd64/PLD/RPMS/ ), and
> failed to find one.  I thought the package ruby-static might have
> them, but apparently not.
> 
> What am I missing here, to get the ruby headers?

I'm having trouble finding a list of the packages available for PLD Linux
(I'm just not all that familiar with that distro), but for a lot of distros
the header files are off in a separate package with a name like "ruby-devel"
or the like. There's often a distinction between the basic runtime support
package (i.e. the interpreter and standard libraries -- just what you need
to run Ruby programs) and the developer support package (which would
additionally include the header files).

Is there maybe a way to search through PLD's packages for the one that
contains the file "ruby.h"? That might be a way to pin it down.


More information about the fxruby-users mailing list