[fxruby-users] Re: FXRuby on OpenBSD

Lyle Johnson lyle at knology.net
Sun Jul 31 20:07:26 EDT 2005

On Aug 1, 2005, at 4:21 AM, brett s hallett wrote:

> I'm having some problems installing FXRuby on OpenBSD 3.7
> -- Note : OpenBSD supplied Ruby 1.8.1 and fox    	 
> version  /mnt/cdrom/3.7/packages/i386/fox-1.1.41.tgz
> If I try to install any FXRuby against these  I get the error message
> " fox  version is expiremental"  ( something like that !) , so
> I removed the above and installed.

Right. Currently, FXRuby is only supported for FOX versions 1.0.x and 
1.2.x, and no others.

> - Ruby 1.8.2
> - fox-1.2.16
> - FXRuby-1.2.6 or 1.2.3 or 1.2.2  ( so I've tried a few versions !! )
> All appears to go well, some warning messages from fox re: "unsigned 
> integer
> variable used" and suggests that some other procedures would be better 
> than
> the one(s) used. But no actual abort of compile.


> However after installing everything the ruby irb test fails in a 
> unusual way
> eg:
> $ irb
> irb(main):001:0> require 'fox12'
> $
> IE: program just drops out, no error messages, if I try require 'fox' 
> I get
> the expected "can't find file". So I assume that the fox12.so does 
> exist
> (which it does) and is found by irb but ruby does not like "something" 
> about
> the file.

Right, there's something wrong when it tries to load fox12.so. I don't 
know how to tell you to debug this, but for starters, are you able to 
run any of the FOX example programs (i.e. those executables from your 
fox-1.2.16 build)? The answer to that question will at least tell us if 
it's something specific to FXRuby, or if it was a FOX-specific issue.

More information about the fxruby-users mailing list