[fxruby-users] Re: FXRuby under Gentoo

lyle at knology.net lyle at knology.net
Wed Jan 26 16:47:59 EST 2005

On Wed, 26 Jan 2005 16:21:10 -0500, William Ramsay <RamsayW at comcast.net> wrote :

> Thanks...

I was able to do some more research on this problem today and updated the
bug report accordingly:


See my latest comment on this one, which is the first entry under the
"Followup" section that appears towards the bottom of the page. I am pretty
sure that, since you're seeing this error message at compile time, you are
in fact using one of the preview releases of Ruby 1.8.2 and not the final
release; the declaration that the compiler's complaining about doesn't
appear in the include files for the final 1.8.2 release.

But that's a moot point: There is still a problem since they've changed the
call sequence for the function in question (st_foreach). So I still need to
figure out what to do about this -- more to the point, is there some change
I can make that fixes it for Ruby 1.8.2 that maintains backwards
compatibility with previous Ruby releases as well (those with the "old"
version of st_foreach).

But I will come up with something brilliant, real soon now. ;) Again, thanks
for your patience.

More information about the fxruby-users mailing list