[fxruby-users] Re: FXRuby does not compile

lyle at knology.net lyle at knology.net
Tue Jan 25 17:43:35 EST 2005

On Tue, 25 Jan 2005 16:20:46 -0500, William Ramsay <RamsayW at comcast.net> wrote :

> The latest version of FXRuby downloaded from Gentoo does not compile.
> The error is:
> FXRuby.cpp:64: error: declaration of C function `void
> st_foreach(st_table*, int
>    (*)(char*, char*, char*), char*)' conflicts with
> /usr/lib/ruby/1.8/i686-linux/intern.h:249: error: previous declaration
> `void
>    st_foreach(st_table*, int (*)(), long unsigned int)' here
> This is for Ruby 1.8 and happens both in FXRuby 1.0.25 (Gentoo latest)
> and FXRuby 1.2.2.

This sounds like one of the known bugs on the FXRuby bug list:


I assumed this bug had been fixed in the final release of Ruby 1.8.2 since I
did *not* encounter this error when compiling FXRuby 1.2.3 on Mac OS X and
Windows. Are you building against Ruby 1.8.2 final, or is it one of the
preview releases?

More information about the fxruby-users mailing list