[fxruby-users] Big tables still segfault with fxruby-1.2.4

lyle at knology.net lyle at knology.net
Fri Feb 25 12:14:24 EST 2005

On Fri, 25 Feb 2005 11:02:56 -0600, David Peoples
<davidp at touringcyclist.com> wrote :

> I assumed you had run my test or something like it and the code had 
> passed, and there was just something different about the platform you're 
> testing on from mine. So it looks like it might come down to some 
> obscure Windows bug? Fancy that. <g> I hope you can find it.

Well, just because we're (so far) only seeing the crash on Windows doesn't
mean that it's a bug in Windows. It is quite possibly a bug in the FXRuby
code that just keeps its mouth shut when running under Mac OS X. ;)

But either way, I consider this extremely high priority and want to get it
fixed ASAP.

> I keep worrying that this will turn out to be some display driver 
> problem, like the bad old Win95 days, where it shows up on just a 
> minority of the systems out there. I really need to bring Linux up to 
> date on this machine and start developing there. Maybe that will be *my* 
> project for this weekend.

I really, really don't think it's a display driver problem (although I used
to do a lot of nightmarish customer support back in those bad old days). Now
that Jamey (for one) has independently confirmed it on his Windows box that
makes it less likely that it's something like that. Of course, I'm not going
to discourage you from switching (or is it switching back?) to Linux either. ;)

More information about the fxruby-users mailing list