[fxruby-users] ext/fox14/extconf.rb

Lyle Johnson lyle at knology.net
Sun Dec 18 10:18:43 EST 2005

On Dec 18, 2005, at 8:23 AM, Thierry Moisan wrote:

> hi, I'm trying to package FXruby for Ubuntu (and by the way for 
> debian) and I get a problem with the "ruby install.rb config" stage.
> Here's what I get as output :
> thierry at modemcable050:~/dev/build/FXRuby-1.4.2$ ruby install.rb config
> install.rb: entering config phase...
> ---> lib
> ---> lib/fox14
> <--- lib/fox14
> <--- lib
> ---> ext
> ---> ext/fox14
> /usr/bin/ruby1.8 
> /home/thierry/dev/build/FXRuby-1.4.2/ext/fox14/extconf.rb
> /home/thierry/dev/build/FXRuby-1.4.2/ext/fox14/extconf.rb:4:in 
> `require': no such file to load -- mkmf (LoadError)
>         from 
> /home/thierry/dev/build/FXRuby-1.4.2/ext/fox14/extconf.rb:4
> config failed
> 'system /usr/bin/ruby1.8 
> /home/thierry/dev/build/FXRuby-1.4.2/ext/fox14/extconf.rb ' failed
> Try 'ruby install.rb --help' for detailed usage.
> If you could explain me what's the problem and if it's my fault or a 
> problem in FXruby, I could finish packaging it for Ubuntu.

The extconf.rb script is trying to require "mkmf", which is one of the 
standard Ruby library modules. The fact that it can't find it indicates 
that something is seriously wrong with your Ruby installation. I'm not 
at all familiar with Ubuntu Linux, but I googled for "ubuntu mkmf" and 
I found a blog post that indicates that you may be missing the 
ruby1.8-dev package. Is that possible? If so, try installing that 
package and trying again.

Good luck, and thanks for making the effort to package this for Ubuntu!

More information about the fxruby-users mailing list