[fxruby-users] Some problems with FXRuby 1.4.2, 1.4.1

Lyle Johnson lyle at knology.net
Tue Aug 23 09:55:30 EDT 2005


On Aug 22, 2005, at 8:43 PM, Sander Jansen wrote:

> hmmm yes:
>
> [sxj at einstein ~]$ irb
> irb(main):001:0> require 'rubygems'
> => false
> irb(main):002:0> require 'fox14'
> => false
> irb(main):003:0> include Fox
> NameError: uninitialized constant Fox
>         from (irb):3
> irb(main):004:0>

OK.

>> Have you tried to
>> just run one of the examples (e.g. "hello.rb") to see what happens?
>
> Yes, same error as above. I think in someway the Ruby installation is
> broken...

Taking the problems one at a time, I'm curious about why the require of 
"rubygems" is failing. Have you actually installed RubyGems yet? It's 
not part of the standard Ruby distro yet, so that would be something 
that you'd need to download separately and install first.



More information about the fxruby-users mailing list