[fxruby-users] Some problems with FXRuby 1.4.2, 1.4.1

Lyle Johnson lyle at knology.net
Mon Aug 22 19:53:21 EDT 2005

On Aug 22, 2005, at 4:17 PM, Sander Jansen wrote:

> I'm probably doing something wrong, but I experience several issues 
> trying to
> install FXRuby here [using gems]
> 1. How do I specify where to look for FOX?
>    I tried --with-fox-include and --with-fox-lib but they give me an 
> error:
>   "gem install fxruby --force --with-fox-include=/usr/include/fox-1.4
> --with-fox-lib=/usr/lib"
>   which results in:
>   "ERROR:  While executing gem ... (OptionParser::InvalidOption)
>     invalid option: --with-fox-include=/usr/include/fox-1.4"

Well, the possibly good news is that I *think* that 
/usr/include/fox-1.4 and /usr/lib are one of the standard directory 
pairs that the build script will check for a FOX installation, so you 
can *probably* get by with just doing:

	gem install fxruby

Despite this, your experiment shows that, apparently, they've changed 
how you pass command-line options through gem install, so I need to 
follow up on this with the RubyGems developers. If you're unable to 
build the code by doing "gem install fxruby", fall back to the tarball 
build for now, per Joel's suggestion.

More information about the fxruby-users mailing list