[fxruby-users] Some problems with FXRuby 1.4.2, 1.4.1

Sander Jansen sander at knology.net
Mon Aug 22 17:17:07 EDT 2005

I'm probably doing something wrong, but I experience several issues trying to 
install FXRuby here [using gems]

1. How do I specify where to look for FOX?

   I tried --with-fox-include and --with-fox-lib but they give me an error:

  "gem install fxruby --force --with-fox-include=/usr/include/fox-1.4 
  which results in:

  "ERROR:  While executing gem ... (OptionParser::InvalidOption)
    invalid option: --with-fox-include=/usr/include/fox-1.4"

2. I'm getting this error while its building FXRuby

  In file included from include/FXRuby.h:747,
                 from include/FXRbCommon.h:90,
                 from core_wrap.cpp:588:
include/FXRbIconSourceVirtuals.h:15: error: invalid covariant return type for 
`virtual FX::FXImage* FXRbIconSource::loadImage(const void*, const 
FX::FXString&) const'
/usr/local/include/fox-1.4/FXIconSource.h:109: error:   overriding `virtual 
FX::FXIcon* FX::FXIconSource::loadImage(const void*, const FX::FXString&) 
make: *** [core_wrap.o] Error 1


More information about the fxruby-users mailing list