[fxruby-users] Re: FXRuby for fox-toolkit-1.4.11?

Jeroen van der Zijp jeroen at fox-toolkit.org
Mon Apr 11 15:31:32 EDT 2005


On Monday 11 April 2005 11:34 am, Laurent Julliard wrote:
> Just speculating here but would it make sense to skip over FXruby 1.4 
> and target 1.6 instead?


Of course, ultimately this will be completely up to Lyle....

However, I can see a few things:

  1. FOX 1.6 will do almost all stuff with utf8, and software which 
     uses FOX will need to be aware of this; at least, all software 
     that currently goes beyond ascii will need some updating.

  2. Since it will likely take an appreciable amount of time for
     software to catch up with FOX 1.6, I do plan to keep FOX 1.4
     around on maintainance status for quite some time. [the latest
     bug-update was yesterday!].

  3. FOX 1.4 is *very* solid code, and I highly recommend everyone 
     to update to this version, especially for mission-critical work;
     it has some very nice additions, for example the new toolbar
     docking stuff, editable tables, thumbnail icon viewing, and 
     so on.

  4. While 1.6 is on a very tight schedule, it isn't out yet, and
     since the introduction of unicode made some api's a bit fluid,
     I don't think Lyle should work against it until it starts to
     solidify into a 1.6; its liable to be a lot of work to stay 
     up-to-date.

  5. I already owe Lyle lunch [or was it steak dinner?] and I'm afraid
     the tab's going to run a even higher with 1.6 ;-) ;-)



Regards,


	- Jeroen






     


More information about the fxruby-users mailing list