[fxruby-users] installation problems

Joel VanderWerf vjoel at PATH.Berkeley.EDU
Sat Apr 2 21:44:33 EST 2005

Jason Wang wrote:
> hi :D i'm using linux, and i tried to install fxruby.. there seem to
> be some problems with config script.. the following are what reported
> in the shell:
> /usr/bin/ruby1.8 /root/FXRuby-1.2.5/ext/fox12/extconf.rb
> /root/FXRuby-1.2.5/ext/fox12/extconf.rb:4:in `require': no such file
> to load --mkmf (LoadError)
>         from /root/FXRuby-1.2.5/ext/fox12/extconf.rb:4
> config failed
> 'system /usr/bin/ruby1.8 /root/FXRuby-1.2.5/ext/fox12/extconf.rb ' failed
> Try 'ruby install.rb --help' for detailed usage.
> tried googling, but it's no help, anyone know what's wrong? 

mkmf.rb is part of the ruby distribution (on my system it's at 
/usr/local/lib/ruby/1.8/mkmf.rb), so maybe there is something wrong in 
there. To see where ruby is looking, you can try this:

/usr/bin/ruby1.8 -e 'p $LOAD_PATH'

You can set the RUBYLIB env var to add paths.

More information about the fxruby-users mailing list