[fxruby-users] FXRuby 1.2.2 binary gem on Windows ..

Riccardo Giannitrapani riccardo at fisica.uniud.it
Fri Nov 5 05:57:49 EST 2004


Hi

any hints/suggestions for my problem of installing the 1.2.2 binary on  
windows? I have downloaded the 1.2.2 gem

http://rubyforge.org/frs/download.php/1613/fxruby-1.2.2-mswin32.gem

but it seems to be incomplete .. if I tray to do a

gem install fxruby-1.2.2-mswin32.gem it complains not finding the fox12  
library in the ext directory (see my previous email) .. I've tried to  
manually open the gem file (renamed it as a tar file and open it with  
winzip) .. it contains two other archives, one called metadata and the  
other data ..

in the data archive it appear to be the fox installation, it contains  
directories for doc, examples, lib, rdo-sources, tests and web, but no ext  
directory and no fox12.so anywhere .. in fact the gem file seems also much  
smaller than the 1.2.1 one ..

Probably I'm doing something wrong .. any help will be really appreciated,  
since I'm stuck on this problem

Thanks a lot, Riccardo

P.S.
I'm using gem 0.8.1 ..



On Tue, 26 Oct 2004 16:52:41 +0200, Riccardo Giannitrapani  
<riccardo at fisica.uniud.it> wrote:

> Hi Lyle
>
> thanks a lot .. it was exactly that (I was sure I've upgraded to the  
> last gem, but it wasn't) ..
>
> Now I have 0.8.1 and it seems to install, but I still get this problem
>
> C:\>gem install fxruby-1.2.2-mswin32.gem
> Attempting local installation of 'fxruby-1.2.2-mswin32.gem'
> Successfully installed fxruby, version 1.2.2
> Installing RDoc documentation for fxruby-1.2.2-mswin32...
> File not found: ext/fox12
>
> And in fact I cannot find the fox12.so anywhere in my ruby installation  
> (the 1.2.1 installed it inside an ext directory below the gems  
> directory) ..
>
> Am I using gem in the proper way? Thanks again for the help.
>
> Riccardo
>
>
>
> On 26 Oct 2004 14:26:56 -0000, lyle at knology.net <lyle at knology.net> wrote:
>
>>
>> On Tue, 26 Oct 2004 11:15:23 +0200, "Riccardo Giannitrapani"
>> <riccardo at fisica.uniud.it> wrote :
>>
>>> I'm tring to install the last binary gem on Windows of FXRuby, 1.2.2 ..
>>> but I get an error, here it is:
>>
>> <snip>
>>
>> Are you using the latest version of RubyGems (version 0.8.1)? There was
>> change in the file format, which accounts for the smaller file size and
>> which would also account for the errors you're seeing if you're using an
>> older version of RubyGems.
>>
>
>
>



-- 
Riccardo Giannitrapani
Dipartimento di Fisica - Room L1-14-BE
Universita` di Udine - Via delle Scienze, 206  Udine (Italy)
Tel (Office): +39-0432-558209
Home Page: http://www.fisica.uniud.it/~riccardo
ICQ# 86590904


More information about the fxruby-users mailing list