[fxruby-users] 1.2 segfault

Hal Fulton hal9000 at hypermetrics.com
Sat Dec 11 00:45:14 EST 2004


Lyle Johnson wrote:
> which is going to try to load your FXRuby 1.0 installation, not an 
> FXRuby 1.2 installation. Is that what you intended? If not, and you're 
> trying to "port" Tycho to the FXRuby 1.2 API, the first step is going to 
> be to change that to:
> 
>     require 'fox12'

OK, in my own code, I did change that. It's just not changed on
rubyforge.

> but then there will be a number of other changes (i.e. to reflect the 
> API changes between FXRuby 1.0 and FXRuby 1.2). That is to say, programs 
> written for FXRuby 1.2 are not backwards-compatible with those written 
> for FXRuby 1.2.

Obviously I need to RTFM, because I didn't know there was a backwards-
compatibility issue.

However, even so, doesn't it fail awfully quickly?? On the create of
the main window?

I'll do some reading...


Thanks,
Hal



More information about the fxruby-users mailing list