[fxruby-users] 1.2 segfault

Lyle Johnson lyle at knology.net
Fri Dec 10 08:12:49 EST 2004

On Dec 9, 2004, at 8:47 PM, Hal Fulton wrote:

> Don't forget that crash I'm seeing...

OK, a preliminary question... I've downloaded the tycho-0.0.7 release 
from RubyForge and see that the very first line of the main program 
(tycho.rb) is:

	require 'fox'

which is going to try to load your FXRuby 1.0 installation, not an 
FXRuby 1.2 installation. Is that what you intended? If not, and you're 
trying to "port" Tycho to the FXRuby 1.2 API, the first step is going 
to be to change that to:

	require 'fox12'

but then there will be a number of other changes (i.e. to reflect the 
API changes between FXRuby 1.0 and FXRuby 1.2). That is to say, 
programs written for FXRuby 1.2 are not backwards-compatible with those 
written for FXRuby 1.2.

More information about the fxruby-users mailing list