[fxruby-users] Fox 1.3.7 and FXRuby 1.2.1

Lyle Johnson lyle at knology.net
Sat Aug 7 11:12:52 EDT 2004

On Aug 7, 2004, at 9:03 AM, Jeff Koppe wrote:

> After deciding to upgrade to Suse 9.1 I had difficulties trying to 
> make Fox
> 1.2.4.

OK, well, we need to address that problem, then! Any details?

> So, on a lark I tried Fox 1.3.7 which configure/make/make installed
> with nary a glitch.


> But, of course, now I'm back to reinstalling my Ruby
> stuff and discovered, as stated, FXRuby 1.2.1 works with the Fox 1.2.x
> versions. Doh!

Yes, FXRuby 1.2.x is only intended for fox-1.2.x.

> Will there be a FXRuby 1.3.x sometime in the near future? Or is it 
> still to
> unstable to deal with?

The answers are "no" and "yes", respectively. ;)

FOX 1.2 has only been the "new stable" version of FOX for a month or so 
now, and FOX 1.3 is now the unstable development branch. Because the 
latter is unstable, its API is likely to change pretty frequently and 
so FXRuby would need to keep in lock-step with it for the two to remain 
compatible -- and this is just more than I'm willing to sign up for. At 
some point, probably not soon, Jeroen will signal that he's slowing 
down development of FOX 1.3 and getting ready to transition it to the 
API-frozen, stable, FOX version 1.4. It is at that time I would start 
the machinery to update FXRuby to 1.4.

More information about the fxruby-users mailing list