[FLVTool2-users] ERROR: undefined method `&' for "\x05":String

Norman Timmler norman.timmler at inlet-media.de
Tue Dec 29 02:30:36 EST 2009


Hi,

FLVTool2 does not run with Ruby versions > 1.8.7

Cheers,
Norman

On Sat, Dec 12, 2009 at 9:47 PM, 김승정 <kuh3h3 at gmail.com> wrote:

> what is this error?
> =======================
>  uname -a
> Linux s4ndy 2.6.32-rc8-kuh3h3-r1 #1 Sat Nov 28 03:52:39 KST 2009 i686
> GNU/Linux
>
>  ruby --version
> ruby 1.9.1p243 (2009-07-16 revision 24175) [i686-linux]
> =============================
>
>  flvtool2 -U nadia.flv
> ERROR: undefined method `&' for "\x05":String
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flv/stream.rb:399:in `read_header'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flv/stream.rb:57:in `initialize'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2/base.rb:272:in `new'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2/base.rb:272:in `open_stream'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2/base.rb:238:in `block in
> process_files'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2/base.rb:225:in `each'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2/base.rb:225:in
> `process_files'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2/base.rb:44:in `execute!'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2.rb:168:in `execute!'
> ERROR: /usr/lib/ruby/site_ruby/1.9.1/flvtool2.rb:228:in `<top (required)>'
> ERROR: /usr/bin/flvtool2:2:in `require'
> ERROR: /usr/bin/flvtool2:2:in `<main>'
> _______________________________________________
> Flvtool2-users mailing list
> Flvtool2-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/flvtool2-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/flvtool2-users/attachments/20091229/298779bd/attachment.html>


More information about the Flvtool2-users mailing list