[FLVTool2-users] Question about flvtool2 error

Sebi Onofrei sebastian.onofrei at eyepartner.com
Mon Jun 16 04:47:07 EDT 2008


Hello,

I am using flvtool2 for quite a while, but can you tell me why this 
error in some larger than usual files that are to be checked with flvtool2?


flvtool2 -U input.flv output.flv

ERROR: EOFError
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/amf_string_buffer.rb:37:in `read'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/amf_string_buffer.rb:243:in `read__STRING'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/audio_tag.rb:56:in `read_header'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/audio_tag.rb:47:in `after_initialize'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/tag.rb:56:in `initialize'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/stream.rb:447:in `new'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/stream.rb:447:in `read_tags'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flv/stream.rb:58:in `initialize'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2/base.rb:272:in `new'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2/base.rb:272:in `open_stream'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2/base.rb:238:in `process_files'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2/base.rb:225:in `each'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2/base.rb:225:in `process_files'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2/base.rb:44:in `execute!'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2.rb:168:in `execute!'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/lib/flvtool2.rb:228
ERROR: /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
ERROR: /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
ERROR: /usr/lib64/ruby/gems/1.8/gems/flvtool2-1.0.6/bin/flvtool2:2
ERROR: /usr/bin/flvtool2:19:in `load'
ERROR: /usr/bin/flvtool2:19


I sorta need a fix to this or at least to find out what's the cause for this error.

With kind regards,
Sebi Onofrei



More information about the Flvtool2-users mailing list