[FLVTool2-users] Getting some errors - help requested

Norman Timmler norman.timmler at inlet-media.de
Tue Jul 24 08:10:36 EDT 2007


Hello,

navigate to the directory where janetest_300.flv is living, then:

flvtool2 -U janetest_300.flv janetest2_300.flv

Worked?

Ciao,
Norman


Am 24.07.2007 13:21 Uhr schrieb "Jane Will" unter <jane at therealnews.com>:

> I have been using FLMDI (http://www.buraks.com/flvmdi/) to inject metadata
> into .flv files so the backward/forward buttons on our video player work.
> This is awkward because I have to download, inject then re-upload -- but it
> does accomplish what we need.
> 
> Now, I'd like to learn to run flvtools2 on the server instead, but I'm having
> trouble figuring it out.  I used the gui interface on FLMDI, so I don't really
> know much about how this works.
> 
> I tried this command:
> 
> flvtool2 -U janetest_300.flv stdout janetest2_300.flv
> 
> but I got this error...
> 
> therea at therealnews.com  <mailto:therea at therealnews.com>
> [~/public_html/media/trn_2006-12-20]# flvtool2 -U janetes    t_300.flv stdout
> janetest2_300.flv
> ERROR: undefined method `[]' for nil:NilClass
> ERROR: /usr/lib64/site_ruby/1.8/flv/stream.rb:138:in `add_meta_tag'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:184:in `add_meta_data_tag'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:137:in `update'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:47:in `send'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:47:in `execute!'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:46:in `each'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:46:in `execute!'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:44:in `process_files'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:225:in `each'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:225:in `process_files'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2/base.rb:44:in `execute!'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2.rb:168:in `execute!'
> ERROR: /usr/lib64/site_ruby/1.8/flvtool2.rb:228
> ERROR: /usr/bin/flvtool2:2:in `require'
> ERROR: /usr/bin/flvtool2:2
> 
> I've read through the examples and the past message threads but I'm not seeing
> any directions that are understandable to me. Can anyone point me in the right
> direction?  
> 
> Thanks,
> Jane
> 
> 
> _______________________________________________
> Flvtool2-users mailing list
> Flvtool2-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/flvtool2-users


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/flvtool2-users/attachments/20070724/ba4ec530/attachment-0001.html 


More information about the Flvtool2-users mailing list