[FLVTool2-users] Problem with 1.0.6 final and 1.0.5 RC6

sir buce sirbuce at gmail.com
Wed Feb 14 06:26:06 EST 2007


Hello all,

I have a problem using flvtool2 1.0.6 final.

When I run flvtool2 with a flv file it display me this error:

ERROR: EOFError ERROR:
/usr/local/lib/site_ruby/1.8/flv/amf_string_buffer.rb:37:in `read' ERROR:
/usr/local/lib/site_ruby/1.8/flv/amf_string_buffer.rb:243:in `read__STRING'
ERROR: /usr/local/lib/site_ruby/1.8/flv/audio_tag.rb:56:in `read_header'
ERROR: /usr/local/lib/site_ruby/1.8/flv/audio_tag.rb:47:in
`after_initialize' ERROR: /usr/local/lib/site_ruby/1.8/flv/tag.rb:56:in
`initialize' ERROR: /usr/local/lib/site_ruby/1.8/flv/stream.rb:447:in `new'
ERROR: /usr/local/lib/site_ruby/1.8/flv/stream.rb:447:in `read_tags' ERROR:
/usr/local/lib/site_ruby/1.8/flv/stream.rb:58:in `initialize' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2/base.rb:272:in `new' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2/base.rb:272:in `open_stream' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2/base.rb:238:in `process_files' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2/base.rb:225:in `each' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2/base.rb:225:in `process_files' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2/base.rb:44:in `execute!' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2.rb:168:in `execute!' ERROR:
/usr/local/lib/site_ruby/1.8/flvtool2.rb:228 ERROR: /usr/bin/flvtool2:2:in
`require' ERROR: /usr/bin/flvtool2:2

I have been looking for the error on  the web and I have found that problem
is because the flvtools tries to read outside the file.

Somebody can help me?

Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/flvtool2-users/attachments/20070214/fbad9aae/attachment.html 


More information about the Flvtool2-users mailing list