[FLVTool2-users] Getting some errors - help requested

Sebastian Knoop-Troullier sebastian at loorimar.com
Thu Aug 16 22:12:51 EDT 2007


phpmotion converts it to flv. I also get the same error if I manually run
flvtool2 against an flv file.

ERROR: undefined method `timestamp' for nil:NilClass
ERROR: /usr/lib/ruby/site_ruby/1.8/flv/stream.rb:285:in `lasttimestamp'
ERROR: /usr/lib/ruby/site_ruby/1.8/flv/stream.rb:274:in `duration'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:181:in
`add_meta_data_tag'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:137:in `update'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:47:in `send'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:47:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:46:in `each'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:46:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:239:in `process_files'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:225:in `each'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:225:in `process_files'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:44:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2.rb:168:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2.rb:228
ERROR: /usr/bin/flvtool2:2:in `require'
ERROR: /usr/bin/flvtool2:2


> flvtool2 works with quicktime files? Or does phpmotion convert to flv?

On 8/14/07, Sebastian Knoop-Troullier <sebastian at loorimar.com
<http://rubyforge.org/mailman/listinfo/flvtool2-users> > wrote:
> Good question.
> This error occurs on a quicktime file which I have uploaded through
> phpmotion.
>
> -----Original Message-----
> From: flvtool2-users-bounces at rubyforge.org
<http://rubyforge.org/mailman/listinfo/flvtool2-users> 
> [mailto:flvtool2-users-bounces at rubyforge.org
<http://rubyforge.org/mailman/listinfo/flvtool2-users> ] On Behalf Of Emmett
Shear
> Sent: Tuesday, August 14, 2007 4:59 PM
> To: flvtool2-users at rubyforge.org
<http://rubyforge.org/mailman/listinfo/flvtool2-users> 
> Subject: Re: [FLVTool2-users] Getting some errors - help requested
>
> > ERROR: /usr/bin/flvtool2:2:in `require'
> > ERROR: /usr/bin/flvtool2:2
> >
> > Any ideas?
> >
>
> I vaguely remember running into a similar issue when I was using
> flvtool2 - my issue had to do with the encoding my flvs were in (VP6 vs.
the
> more standard Sorennson). Do you know the encoding for your files?
>
> - Emmett
> _______________________________________________
> Flvtool2-users mailing list
> Flvtool2-users at rubyforge.org
<http://rubyforge.org/mailman/listinfo/flvtool2-users> 
> http://rubyforge.org/mailman/listinfo/flvtool2-users
>
> _______________________________________________
> Flvtool2-users mailing list
> Flvtool2-users at rubyforge.org
<http://rubyforge.org/mailman/listinfo/flvtool2-users> 
> http://rubyforge.org/mailman/listinfo/flvtool2-users




More information about the Flvtool2-users mailing list