[FLVTool2-users] Question regarding XML syntax for onCuePoint metatags.

Norman Timmler lists at inlet-media.de
Sat Mar 4 05:17:05 EST 2006


Am Dienstag, den 28.02.2006, 18:22 +0100 schrieb erixtekila:
> > I am having trouble when inserting onCuePoint metatags using flvtool2.
> >
> > I use the following command (OS is Linux and FLVTool2 version is
> > 1.0.3 RC4):
> >
> > flvtool2 -UAt /tmp/tags.xml /tmp/file.flv
> >
> >
> > I'd be glad if someone could hint me as to why my timestamps doesn't
> > work and why I seem to have to run the -UAt command twice in order
> > for any cuepoints to show up!

> I can confirm that on osx too.
> 
> One need two pass of flvtool2 -UAt /tmp/tags.xml /tmp/file.flv to add 
> the cuepoints to the flv.
> 
> I also tried to pipe he process without any luck.
> I was thinking that flvtool2 needs a pass wih -U and use the infos to 
> add the cuepoints :
> ./flvtool2 -U /Users/via/Desktop/demo.flv stdout | ./flvtool2 -At 
> /Users/via/Desktop/tags.xml stdin /Users/via/Desktop/test.flv

Piping makes no difference, because the file is simply read from another
location (stdin).

> BTW, we are only talking of the cuepoints list added in the header 
> file, as I don't took time to test them as events for now…

Ah, ok. That's no bug. It is a failure in your command chaining:

flvtool2 -AUt /tmp/tags.xml /tmp/file.flv

Notice U and A have changed places. Commands are executed in the order
you write them down.

> I think there is also an issue with the line type of the tags.xml file.
> It seems to use \n only, not \n\r neither \r.

Right, please make a bug report at:

http://projects.inlet-media.de/flvtool2/newticket

Thank you.
-- 
Norman Timmler

http://blog.inlet-media.de



More information about the Flvtool2-users mailing list