[FLVTool2-users] Solution to cue points not appearing in Flash + 1000msec problem

Kefentse Account kefentse at kefentse.com
Tue Jul 18 00:08:58 EDT 2006


Hi Oszkar,

I get the error when I attempt to run this script from the shell :

flvtool2 -P meta_test.flv

Not sure what would create the error:

ERROR: undefined method `&' for "\005":String

How do you usually troubleshoot? Also, does anyone have FLVTool2 working 
with Ruby 1.9? Could that be causing a problem?

Thanks again for any help you can provide.

Oszkar Nagy wrote:
> Hi!
>
> Well from what I discovered so far I think my issue is NOT due to a  
> bug in flvtool2. Here is what I found:
>
> If I inject data from an XML using (flvtool2 -AUt myxml.xml input.flv  
> output.flv) the data is actually in the FLV file and all the cue  
> points invoke the onCuePoint event. Although you can't read them (I  
> am no professional in AS2 so I might be wrong) from the cuePoints  
> array as they all return undefined. This was a problem for me as I  
> wanted to have access to all my data as soosn as the FLV has been  
> loaded. So what I did in my particular case is I created a cue point  
> at 0 timestamp and added all my data as parameters. This would fire  
> up at the start of the FLV and parse all the data from the parameters  
> to associative arrays, so that I have all my information before  
> reaching any other cue points. Also sometimes if I put two cue points  
> closer than 1000 msec I got an "Unsorted cue point" error using the  
> Flash 7 media components (have to use those in this particular  
> project) to play back the FLV. So I think this is a bug in Flash.
>
> Erixtekila:
> Tried both with the same result.
>
> Kefentse Account:
> Regarding your problem, most of the time I got an error message like  
> this something is wrong syntactically so check how do you run  
> flvtool2. Check escaped characters, and check how you put your  
> parameters and your piping as well if you do that. If you are  
> injecting from xml check the format of you xml and also the line  
> endings and the file encoding. I had several problems which were due  
> to my XML was not formatted properly (as I am generating them  
> automatically).
>
> Cheers,
>
> Oszkar
>
> _______________________________________________
> Flvtool2-users mailing list
> Flvtool2-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/flvtool2-users
>
>
>   



More information about the Flvtool2-users mailing list