[FLVTool2-users] FLVTool on Mac OS X

Oszkar Nagy oszkar.nagy at gmail.com
Mon Jul 3 11:42:54 EDT 2006


Hi!

Two cases regarding flvtool2 where I don't know what to do.

1.
Tried to inject cue points from a valid xml-file following the  
structure of the sample xml with the command:

flvtool2 -AUPt myxml.xml input.flv output.flv

It did inject the tags according to the information printed on the  
screen however if I load the file in Flash, it does not see any cue  
points, and the hasCuePoints element is false. I tried changing the  
line endings as well but nothing happened.


2.
All worked fine up until I updated my system from 10.4.6 to 10.4.7.  
after executing the same command I get:
ERROR: undefined method `each' for nil:NilClass
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:82:in `add'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:47:in `send'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:47:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:46:in `each'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:46:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:44:in  
`process_files'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:225:in `each'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:225:in  
`process_files'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2/base.rb:44:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2.rb:168:in `execute!'
ERROR: /usr/lib/ruby/site_ruby/1.8/flvtool2.rb:228
ERROR: /usr/bin/flvtool2:2:in `require'
ERROR: /usr/bin/flvtool2:2

Any ideas on theese?

Oszkar Nagy






More information about the Flvtool2-users mailing list