[ditz-talk] problems on 1.9.2 (patch included)

Stephen Waits steve at waits.net
Tue Feb 22 13:57:08 EST 2011


Hi,

ditz 0.5 wouldn't run on my 1.9.2 installation.

There were two problems..

1) require 'sha1' needed to be require 'digest/sha1'

2) ruby complained about "multiple assignment in conditional" in several 
cases where you were doing something like "if (found,x = generate..()) 
&& found".

I've attached a patch which I believe fixes these issues.

I hope you'll incorporate a fix (mine or otherwise) and re-release the 
gem so I can run the blessed version, instead of my local fork. :)

Thanks,
Steve
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: model.rb.patch
URL: <http://rubyforge.org/pipermail/ditz-talk/attachments/20110222/bf9c1924/attachment-0001.pl>


More information about the ditz-talk mailing list