[ditz-talk] licensing

William Morgan wmorgan-ditz at masanjin.net
Wed Sep 30 12:39:20 EDT 2009


Reformatted excerpts from Jan Klepek's message of 2009-09-27:
> unfortunately not :/ 
> in trollop.rb:
> ## License::   GNU GPL version 2
> and GPLv3(and later) is not compatible with GPLv2.
> 
> If it is possible to add explicit clause for Trollop, it would be great
> and help to get ditz into Fedora. Could you please let me know where I
> could later find this clause?

I'm about to release a new version of Trollop, and I'm happy to add such
a clause.

However, the *actual* license of Trollop, despite what trollop.rb says,
is what's in the README.txt: "Trollop is distributed under the same
terms as Ruby". Ruby is distributed under GPL v2 *or* a bunch of special
clauses: http://www.ruby-lang.org/en/LICENSE.txt.

So based on whether that license is acceptable to GPLv3 or not, I will
update the readme to have an explicit clause for ditz or not. And either
way, I will update trollop.rb to match the readme.

Hope I'm not being overly difficult. :)
-- 
William <wmorgan-ditz at masanjin.net>


More information about the ditz-talk mailing list