[ditz-talk] licensing

Jan Klepek jan.klepek at brandforge.sk
Sun Sep 27 14:39:22 EDT 2009


On Sun, 2009-09-27 at 10:48 -0700, William Morgan wrote:
> Reformatted excerpts from jan.klepek's message of 2009-09-25:
> > Trollop license (GPLv2) is not compatible with Ditz license (GPLv3+).
> > So from Licensing point of view, it needs explicit statement in README
> > or in Code that linking to trollop library is allowed.
> 
> Trollop is licensed "under the same terms as Ruby itself". Is that
> sufficient for GPLv3 compatibility? If not, I will add an explicit
> clause to Trollop.
unfortunately not :/ 
in trollop.rb:
## License::   GNU GPL version 2
and GPLv3(and later) is not compatible with GPLv2.

If it is possible to add explicit clause for Trollop, it would be great
and help to get ditz into Fedora. Could you please let me know where I
could later find this clause?

Thanks,

Regards,
Jan Klepek



More information about the ditz-talk mailing list