[ditz-talk] [PATCH] don't require .ditz-plugins

Kouhei Sutou kou at clear-code.com
Fri Dec 18 03:33:02 EST 2009


Hi,

I noticed that ditz requires .ditz-plugins file. If I don't
have .ditz-plugins, I can't run any commands (including
'init' command).

  % mkdir -p /tmp/sample
  % cd /tmp/sample
  % ditz
  /usr/lib/ruby/1.8/yaml.rb:143:in `initialize': No such file or directory - ./.ditz-plugins (Errno::ENOENT)
          from /usr/lib/ruby/1.8/yaml.rb:143:in `open'
          from /usr/lib/ruby/1.8/yaml.rb:143:in `load_file'
          from /home/kou/work/ruby/ditz/lib/ditz.rb:55:in `load_plugins'
          from /home/kou/work/ruby/ditz/bin/ditz:92

I'll attach a patch that makes .ditz-plugins file optional.


Thanks,
--
kou
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-don-t-require-.ditz-plugins.patch
Type: text/x-patch
Size: 853 bytes
Desc: not available
URL: <http://rubyforge.org/pipermail/ditz-talk/attachments/20091218/32737534/attachment.bin>


More information about the ditz-talk mailing list