[ditz-talk] [ANN] ditz 0.5 distributed issue tracker released

William Morgan wmorgan-ditz at masanjin.net
Thu Aug 21 15:52:26 EDT 2008

Reformatted excerpts from Christian Garbs's message of 2008-08-21:
> I don't want to be nitpicky, now that setup.rb is included, but I've
> come across trollop.rb which is included in the ditz 0.5 gem and tgz.
> As trollop is a separate package, shouldn't it be excluded from the
> ditz release?

I included it because I want the tarball to be useful for people without
rubygems. Ideally it should be included by the tarball and excluded by
the gem, but that's hard.

> Also, trollop.rb claims VERSION = "1.8.2", I thought that ditz 0.5
> needed trollop 1.9.

That's a fuckup on my part. (I've corrected it in git.) I copied that
file over from trollop before bumping the version number.  The code is
1.9; it's just the version number in there that's wrong.

I appreciate your help ironing out all these issues. It sounds like by
0.6 we should have a tarball that you can automatically Debianize. Maybe
next time I'll actually try and see that everything's working before
just releasing it into the wild. :)
William <wmorgan-ditz at masanjin.net>

More information about the ditz-talk mailing list