[Backgroundrb-devel] Building git on ubuntu

Mike Dupont jamesmikedupont at googlemail.com
Sat Apr 30 15:29:25 EDT 2011


 2006  git clone git://github.com/gnufied/backgroundrb.git
 2011  sudo apt-get install ruby
 2016  sudo apt-get install rake
  sudo apt-get install rubygems
  sudo gem install rspec -v=1.3
  sudo gem install mocha
  sudo gem install test-unit
  sudo gem install test-spec
  sudo gem install rails
  pushd /var/lib/gems/1.8/gems/rails-3.0.7/
  mkdir lib
popd
 2070  sudo gem install rails
 2079  sudo gem install packet

Now it wants  bdrb_config.rb which is in the module itself
  find -name bdrb_config.rb
./lib/backgroundrb/bdrb_config.rb
  rake --trace
mdupont at space-station:~/experiments/ruby/backgroundrb$ rake --trace
(in /home/mdupont/experiments/ruby/backgroundrb)
** Invoke default (first_time)
** Invoke test (first_time)
** Execute test
/usr/bin/ruby1.8 -I"lib:lib"
"/usr/lib/ruby/1.8/rake/rake_test_loader.rb"
"test/client/test_bdrb_job_queue.rb"
"test/client/test_bdrb_client_helper.rb"
"test/client/test_bdrb_config.rb"
"test/client/test_bdrb_connection.rb"
"test/client/test_worker_proxy.rb"
"test/client/test_bdrb_cluster_connection.rb"
"test/server/test_master_proxy.rb"
"test/server/test_result_storage.rb"
"test/server/test_master_worker.rb" "test/server/test_meta_worker.rb"
"test/server/test_cron_trigger.rb"
/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- bdrb_config
(LoadError)
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from ./test/client/../bdrb_test_helper.rb:31
	from ./test/client/test_bdrb_job_queue.rb:1:in `require'
	from ./test/client/test_bdrb_job_queue.rb:1
	from /usr/lib/ruby/1.8/rake/rake_test_loader.rb:5:in `load'
	from /usr/lib/ruby/1.8/rake/rake_test_loader.rb:5
	from /usr/lib/ruby/1.8/rake/rake_test_loader.rb:5:in `each'
	from /usr/lib/ruby/1.8/rake/rake_test_loader.rb:5
rake aborted!
Command failed with status (1): [/usr/bin/ruby1.8 -I"lib:lib" "/usr/lib/rub...]
/usr/lib/ruby/1.8/rake.rb:995:in `sh'
/usr/lib/ruby/1.8/rake.rb:1010:in `call'
/usr/lib/ruby/1.8/rake.rb:1010:in `sh'
/usr/lib/ruby/1.8/rake.rb:1094:in `sh'
/usr/lib/ruby/1.8/rake.rb:1029:in `ruby'
/usr/lib/ruby/1.8/rake.rb:1094:in `ruby'
/usr/lib/ruby/1.8/rake/testtask.rb:117:in `define'
/usr/lib/ruby/1.8/rake.rb:1112:in `verbose'
/usr/lib/ruby/1.8/rake/testtask.rb:102:in `define'
/usr/lib/ruby/1.8/rake.rb:636:in `call'
/usr/lib/ruby/1.8/rake.rb:636:in `execute'
/usr/lib/ruby/1.8/rake.rb:631:in `each'
/usr/lib/ruby/1.8/rake.rb:631:in `execute'
/usr/lib/ruby/1.8/rake.rb:597:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/1.8/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:607:in `invoke_prerequisites'
/usr/lib/ruby/1.8/rake.rb:604:in `each'
/usr/lib/ruby/1.8/rake.rb:604:in `invoke_prerequisites'
/usr/lib/ruby/1.8/rake.rb:596:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/1.8/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:583:in `invoke'
/usr/lib/ruby/1.8/rake.rb:2051:in `invoke_task'
/usr/lib/ruby/1.8/rake.rb:2029:in `top_level'
/usr/lib/ruby/1.8/rake.rb:2029:in `each'
/usr/lib/ruby/1.8/rake.rb:2029:in `top_level'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:2023:in `top_level'
/usr/lib/ruby/1.8/rake.rb:2001:in `run'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:1998:in `run'
/usr/bin/rake:28
mdupont at space-station:~/experiments/ruby/backgroundrb$ git status
# On branch master
nothing to commit (working directory clean)

mdupont at space-station:~/experiments/ruby/backgroundrb$ git remote show origin

  Fetch URL: git://github.com/gnufied/backgroundrb.git
  Push  URL: git://github.com/gnufied/backgroundrb.git


please advise
Architecture: i386
Date: Sat Apr 30 21:29:07 2011
Dependencies:
  coreutils 8.5-1ubuntu3
  debconf 1.5.32ubuntu3
  debconf-i18n 1.5.32ubuntu3
  dpkg 1.15.8.4ubuntu3.1
  findutils 4.4.2-1ubuntu1
  gcc-4.5-base 4.5.1-7ubuntu2
  libacl1 2.2.49-3
  libattr1 1:2.4.44-2
  libbz2-1.0 1.0.5-4ubuntu1
  libc-bin 2.12.1-0ubuntu10.2
  libc6 2.12.1-0ubuntu10.2
  libgcc1 1:4.5.1-7ubuntu2
  libgdbm3 1.8.3-9
  liblocale-gettext-perl 1.05-6
  liblzma2 4.999.9beta+20100527-1
  libncurses5 5.7+20100626-0ubuntu1
  libreadline5 5.2-7build1
  libruby1.8 1.8.7.299-2
  libselinux1 2.0.94-1
  libssl0.9.8 0.9.8o-1ubuntu4.4
  libtext-charwidth-perl 0.04-6
  libtext-iconv-perl 1.7-2
  libtext-wrapi18n-perl 0.06-7
  perl-base 5.10.1-12ubuntu2
  readline-common 6.1-3
  ruby1.8 1.8.7.299-2
  tzdata 2011e-0ubuntu0.10.10
  xz-utils 4.999.9beta+20100527-1
  zlib1g 1:1.2.3.4.dfsg-3ubuntu1
DistroRelease: Ubuntu 10.10
NonfreeKernelModules: nvidia
Package: ruby 4.5
PackageArchitecture: all
ProblemType: Bug
ProcEnviron:
  SHELL=/bin/bash
  LANG=C
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
SourcePackage: ruby-defaults
Tags:  ubuntu-une maverick
Uname: Linux 2.6.35-28-generic i686


-- 
James Michael DuPont
Member of Free Libre Open Source Software Kosova and Albania
flossk.org flossal.org


More information about the Backgroundrb-devel mailing list