[Backgroundrb-devel] Client disconected error - trying to upgrade to latest version of backgroundrb

Grant Blakeman grant.blakeman at gmail.com
Tue Sep 23 18:51:54 EDT 2008

Hi Kieran,
I'm on a Mac. I was running packet 0.1.12, so I tried downgrading to
0.1.7.But I'm still getting the same behavior: an immediate "Client
in the log whenever I try to call a new worker or ask an existing one to do

Could there be more info somewhere other than the debug log that I might be
able to check and see what's going on?


On Mon, Sep 22, 2008 at 8:30 PM, Kieran P <kieran776 at gmail.com> wrote:

> Hello Grant,
> Out of curiosity, are you using a Mac or Linux?
> If Mac, try downgrading the packet gem to 0.1.7. Later versions include a
> raise line that I found causes similar problems for me.
> And if Linux, try upgrading to the latest. I believe 0.1.13 contains fixes
> related to packet on linux.....
> Regards
> Kieran
> On Tue, Sep 23, 2008 at 1:09 PM, Grant Blakeman <grant.blakeman at gmail.com>wrote:
>> Hi, I've tried it both ways (:arg & :args) and still get the same 'Client
>> disconected' in the debug log. I also tried simplifying the call to see if
>> any of the arguments were the problem:
>> MiddleMan.worker(:danny_worker).async_do_work(:arg => "
>> grant.blakeman at gmail.com")
>> and I still get the error. It seems like the disconnect happens before it
>> even reads anything in the worker file. I tried calling an argument that
>> wasn't in the worker:
>> MiddleMan.worker(:danny_worker).async_should_not_work(:arg => "
>> grant.blakeman at gmail.com")
>> and simply got the 'Client disconected' error.
>> Any ideas?
>> -gb

-Grant Blakeman
grant.blakeman at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20080923/c89f7685/attachment.html>

More information about the Backgroundrb-devel mailing list