[Backgroundrb-devel] "Client disconected" error - trying to upgrade to latest version of backgroundrb

Grant Blakeman grant.blakeman at gmail.com
Thu Sep 18 13:06:58 EDT 2008

Hi, I've had a project using a really old version of backgroundrb (don't
remember which one) to simply send out some e-mails in the background. I'm
currently trying to upgrade the project so that I can learn more about
backgroundrb and use some of its other features.
I've tried rewriting my worker call to work with the latest version (see
below), but every time I try it, the debug log simply prints 'Client
disconected' and nothing happens. Am I doing something wrong?

In my controller:

MiddleMan.worker(:david_worker).async_do_work(:args => { :email =>
                      :url => @user.reset_password_code,
                      :mail_type => :forgot_password_email })


In my worker:

  set_worker_name :david_worker

  def create(args = nil)
    # this method is called, when worker is loaded for the first time

  def do_work(args)
    Notifier.send("deliver_#{args[:mail_type]}", args)

Thanks in advance for any tips!

-Grant Blakeman
grant.blakeman at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20080918/0cce69dc/attachment.html>

More information about the Backgroundrb-devel mailing list