[Backgroundrb-devel] error starting backgroundrb

Aslan Neishaboori aneishaboori at socialvibe.com
Wed Oct 22 17:22:13 EDT 2008


its been two days that i am struggling with this error. i have  
followed all the instructions in http://backgroundrb.rubyforge.org.

when i start the server i get the following error

   1. /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb: 
27:in `gem_original_require': no such file to load --  
task_alert_worker (LoadError)
   2.   from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/ 
custom_require.rb:27:in `require'
   3.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:35:in `load_worker'
   4.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:26:in `initialize'
   5.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:47:in `new'
   6.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:47
   7.   from /opt/local/bin/packet_worker_runner:19:in `load'
   8.   from /opt/local/bin/packet_worker_runner:19
   9. /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb: 
27:in `gem_original_require': no such file to load --  
task_alert_worker (LoadError)
  10.   from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/ 
custom_require.rb:27:in `require'
  11.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:35:in `load_worker'
  12.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:26:in `initialize'
  13.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:47:in `new'
  14.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/ 
packet_worker_runner:47
  15.   from /opt/local/bin/packet_worker_runner:19:in `load'
  16.   from /opt/local/bin/packet_worker_runner:19



somewhere i read that this can be fixed by rolling back the packet gem  
to version 0.1.5. it did fix the start up problem but then when i call  
a worker from the console i get the following error which i guess has  
to do with the dependency.

   1. /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/ 
active_support/dependencies.rb:279:in `load_missing_constant':  
uninitialized constant Packet::BinParser (NameError)
   2.   from /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/ 
active_support/dependencies.rb:468:in `const_missing'
   3.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/server/lib/master_worker.rb:165:in `post_init'
   4.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_connection.rb:21:in `invoke_init'
   5.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:302:in `decorate_handler'
   6.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:76:in `accept_connection'
   7.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:202:in `handle_external_messages'
   8.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:178:in `handle_read_event'
   9.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:174:in `each'
  10.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:174:in `handle_read_event'
  11.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:130:in `start_reactor'
  12.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:124:in `loop'
  13.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:124:in `start_reactor'
  14.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:21:in `run'
  15.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/server/lib/master_proxy.rb:14:in `initialize'
  16.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in `new'
  17.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in `start'
  18.   from ./script/backgroundrb:35
  19. /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_nbio.rb:25:in `read_data': Packet::DisconnectError  
(Packet::DisconnectError)
  20.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_worker.rb:46:in `handle_internal_messages'
  21.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:176:in `handle_read_event'
  22.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:174:in `each'
  23.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:174:in `handle_read_event'
  24.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:130:in `start_reactor'
  25.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:124:in `loop'
  26.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:124:in `start_reactor'
  27.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_worker.rb:20:in `start_worker'
  28.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:133:in `fork_and_load'
  29.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:96:in `load_workers'
  30.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:91:in `each'
  31.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:91:in `load_workers'
  32.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:20:in `run'
  33.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/server/lib/master_proxy.rb:14:in `initialize'
  34.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in `new'
  35.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in `start'
  36.   from ./script/backgroundrb:35
  37. /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_nbio.rb:25:in `read_data': Packet::DisconnectError  
(Packet::DisconnectError)
  38.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_worker.rb:46:in `handle_internal_messages'
  39.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:176:in `handle_read_event'
  40.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:174:in `each'
  41.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:174:in `handle_read_event'
  42.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:130:in `start_reactor'
  43.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:124:in `loop'
  44.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_core.rb:124:in `start_reactor'
  45.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_worker.rb:20:in `start_worker'
  46.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:133:in `fork_and_load'
  47.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:108:in `start_worker'
  48.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/server/lib/master_proxy.rb:16:in `initialize'
  49.   from /opt/local/lib/ruby/gems/1.8/gems/packet-0.1.5/lib/packet/ 
packet_master.rb:19:in `run'
  50.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/server/lib/master_proxy.rb:14:in `initialize'
  51.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in `new'
  52.   from /Users/aslan/Documents/Aptana Studio/play/vendor/plugins/ 
backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in `start'
  53.   from ./script/backgroundrb:35


i am running os x.
my gem versions :
*** LOCAL GEMS ***

actionmailer (2.1.1, 1.3.5)
actionpack (2.1.1, 1.13.5)
actionwebservice (1.2.5)
activerecord (2.1.1, 1.15.5)
activeresource (2.1.1)
activesupport (2.1.1, 1.4.4)
arrayfields (4.6.0)
capistrano (2.5.0)
capistrano-ext (1.2.1)
cgi_multipart_eof_fix (2.5.0)
cheat (1.2.1)
chronic (0.2.3)
daemons (1.0.10)
eventmachine (0.12.2)
fastercsv (1.4.0)
fastthread (1.0.1)
fattr (1.0.3)
gem_plugin (0.2.3)
git (1.0.5)
git-rails (0.2.1)
highline (1.4.0)
hoe (1.7.0)
hpricot (0.6.161)
libxml-ruby (0.8.3)
main (2.8.2)
memcache-client (1.5.0)
mongrel (1.1.5)
mysql (2.7)
net-scp (1.0.1)
net-sftp (2.0.1)
net-ssh (2.0.4)
net-ssh-gateway (1.0.0)
packet (0.1.14)
rails (2.1.1, 1.2.5)
rake (0.8.3)
rubyforge (1.0.0)
starling (0.9.8)
SyslogLogger (1.4.0)
ZenTest (3.10.0)

by the way every time i changed something i removed ./script/ 
load_worker_env.rb and ./script/backgroundrb and ran
rake backgroundrb:setup

how can i fix this problem.

aslan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20081022/7704487b/attachment-0001.html>


More information about the Backgroundrb-devel mailing list