[Backgroundrb-devel] Error starting Backgroundrb

John Miller jmillr at umich.edu
Wed Oct 15 13:57:52 EDT 2008


I reported a similar error on Leopard on Sept. 12th (check archives).  
Hemant suggested the following, which worked for me, but the context  
was running 'god':

> Looks like, PATH is not proper when god is automatically starting it.
> Check if "packet_worker_runner" script is in PATH.Its a executable,  
> that
> packet installs when gem gets installed.

I'm not sure where you'd set the PATH so packet_worker_runner can find  
your workers. Somehow, you want to add the

/Library/Ruby/Gems/1.8/.../packet_worker_runner

path somewhere.

By the way, since you're on Leopard, you may have more luck running  
your own versions of ruby and rubygems by following these excellent  
instructions:

http://hivelogic.com/articles/2008/02/ruby-rails-leopard

John

On Oct 15, 2008, at 1:15 PM, Adam Kenger wrote:

> Hi all.  I'm hoping this is a really simple issue, but I've been  
> scouring the web for a few hours and have come up with nothing.
>
> I am running the newest backgroundrb from git (1.1) on a Mac running  
> Leopard. Environment below.
>
> I have installed packet 0.1.14 and chronic 0.2.3 as well as run the  
> setup rake task (and made sure all my files in the script/ directory  
> were cleaned out).
>
> When I start backgroundrb -
>
> /script/backgroundrb start
>
> I get the following in the debug log
>
> /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in  
> `gem_original_require': no such file to load -- log_worker (LoadError)
>         from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in  
> `require'
>         from /Library/Ruby/Gems/1.8/gems/packet-0.1.14/bin/ 
> packet_worker_runner:35:in `load_worker'
>         from /Library/Ruby/Gems/1.8/gems/packet-0.1.14/bin/ 
> packet_worker_runner:26:in `initialize'
>         from /Library/Ruby/Gems/1.8/gems/packet-0.1.14/bin/ 
> packet_worker_runner:47:in `new'
>         from /Library/Ruby/Gems/1.8/gems/packet-0.1.14/bin/ 
> packet_worker_runner:47
>         from /usr/bin/packet_worker_runner:19:in `load'
>         from /usr/bin/packet_worker_runner:19
>
> The server is running, but when it tries to run one of my workers,  
> it reports the same "no such file to load" error.
>
> Can anyone help out?
>
> Thanks in advance
>
> Adam Kenger
>
> -------------------------
>
>
>
> RubyGems Environment:
>   - RUBYGEMS VERSION: 1.2.0
>   - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [universal- 
> darwin9.0]
>   - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
>   - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/ 
> Versions/1.8/usr/bin/ruby
>   - EXECUTABLE DIRECTORY: /usr/bin
>   - RUBYGEMS PLATFORMS:
>     - ruby
>     - universal-darwin-9
>   - GEM PATHS:
>      - /Library/Ruby/Gems/1.8
>      - /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/ 
> lib/ruby/gems/1.8
>   - GEM CONFIGURATION:
>      - :update_sources => true
>      - :verbose => true
>      - :benchmark => false
>      - :backtrace => false
>      - :bulk_threshold => 1000
>      - :sources => ["http://gems.rubyforge.org/", "http://gems.github.com 
> "]
>   - REMOTE SOURCES:
>      - http://gems.rubyforge.org/
>      - http://gems.github.com
>
>
> *** LOCAL GEMS ***
>
> actionmailer (2.1.1, 2.1.0, 2.0.2, 1.3.6, 1.3.3)
> actionpack (2.1.1, 2.1.0, 2.0.2, 1.13.6, 1.13.5, 1.13.3)
> actionwebservice (1.2.6)
> activerecord (2.1.1, 2.1.0, 2.0.2, 1.15.6, 1.15.5, 1.15.3)
> activeresource (2.1.1, 2.1.0, 2.0.2)
> activesupport (2.1.1, 2.1.0, 2.0.2, 1.4.4, 1.4.2)
> acts_as_ferret (0.4.3, 0.4.1)
> adzap-ar_mailer (1.4.3)
> bcrypt-ruby (2.0.3, 2.0.2)
> capistrano (2.5.0, 2.4.3, 2.2.0, 2.1.0, 2.0.0)
> cgi_multipart_eof_fix (2.5.0)
> chronic (0.2.3)
> composite_primary_keys (0.9.93)
> daemons (1.0.10, 1.0.9)
> dnssd (0.7.0, 0.6.0)
> fastthread (1.0.1)
> fcgi (0.8.7)
> ferret (0.11.6, 0.11.4)
> gem_plugin (0.2.3)
> highline (1.4.0, 1.2.9)
> hoe (1.8.0, 1.7.0)
> hpricot (0.6.161, 0.6)
> libxml-ruby (0.8.3, 0.5.4, 0.5.2.0)
> linecache (0.43)
> mongrel (1.1.5, 1.1.4, 1.1.2)
> mysql (2.7)
> needle (1.3.0)
> net-scp (1.0.1)
> net-sftp (2.0.1, 1.1.1, 1.1.0)
> net-ssh (2.0.4, 2.0.3, 1.1.2)
> net-ssh-gateway (1.0.0)
> packet (0.1.14)
> rails (2.1.1, 2.1.0, 2.0.2, 1.2.6, 1.2.3)
> rake (0.8.3, 0.8.1, 0.7.3)
> RedCloth (4.0.4, 4.0.1, 3.0.4)
> ruby-debug-base (0.10.2, 0.10.1, 0.10.0)
> ruby-debug-ide (0.3.1, 0.2.0, 0.1.10)
> ruby-openid (2.1.2, 2.0.4, 2.0.1, 1.1.4)
> ruby-yadis (0.3.4)
> rubyforge (1.0.0)
> rubygems-update (1.3.0, 1.2.0, 1.1.1, 0.9.5)
> rubynode (0.1.5, 0.1.4, 0.1.3)
> sources (0.0.1)
> sqlite3-ruby (1.2.4, 1.2.2, 1.2.1)
> termios (0.9.4)
>
> _______________________________________________
> Backgroundrb-devel mailing list
> Backgroundrb-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/backgroundrb-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20081015/7c9f4ed9/attachment.html>


More information about the Backgroundrb-devel mailing list