[Backgroundrb-devel] Problem while starting the server

Michal Szapiel nicpon at nicpon.net
Wed Nov 26 13:44:52 EST 2008


Hello,
I have followed installation instructions, but I can't get the server to
start. I get following message in the log:
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:477:in
`const_missing': uninitialized constant Packet::Reactor::UNIXSocket
(NameError)
    from
c:/ruby/lib/ruby/gems/1.8/gems/packet-0.1.14/lib/packet/packet_master.rb:98:in
`fork_and_load'
    from
c:/ruby/lib/ruby/gems/1.8/gems/packet-0.1.14/lib/packet/packet_master.rb:80:in
`start_worker'
    from
C:/AOL/branch/workers/AlliedTesting/vendor/plugins/backgroundrb/server/lib/master_proxy.rb:16:in
`initialize'
    from
c:/ruby/lib/ruby/gems/1.8/gems/packet-0.1.14/lib/packet/packet_master.rb:19:in
`run'
    from
C:/AOL/branch/workers/AlliedTesting/vendor/plugins/backgroundrb/server/lib/master_proxy.rb:14:in
`initialize'
    from
C:/AOL/branch/workers/AlliedTesting/config/../vendor/plugins/backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in
`new'
    from
C:/AOL/branch/workers/AlliedTesting/config/../vendor/plugins/backgroundrb/lib/backgroundrb/bdrb_start_stop.rb:50:in
`start'
    from script/backgroundrb:35

Have anyone had this problem? I tried looking for all the dependencies and
it seems to me that they are there, yet I still get this error.
Thanks,
Mike
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20081126/f1d059d1/attachment.html>


More information about the Backgroundrb-devel mailing list