[Backgroundrb-devel] BackgrounDRB Ver. 1.0.3 install troubles.

John Wells lists at sourceillustrated.com
Mon Mar 3 00:09:35 EST 2008


On Sun, Mar 2, 2008 at 12:55 AM, hemant kumar <gethemant at gmail.com> wrote:
>
>  On Sat, 2008-03-01 at 23:31 -0500, Benjamin H. Bryant wrote:
>  > So, after deleting the old version, I have tried getting the files
>  > from both gitorious and SVN using Piston.  Both locations left me with
>  > this error on startup:
>  >
>  > /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
>  > `gem_original_require': no such file to load -- meta_worker
>  > (MissingSourceFile)
>  >       from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
>  > 27:in `require'
>  >       from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
>  > active_support/dependencies.rb:496:in `require'
>  >       from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
>  > active_support/dependencies.rb:342:in `new_constants_in'
>  >       from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
>  > active_support/dependencies.rb:496:in `require'
>  >       from script/backgroundrb:17
>  >
>  >
>  > Ideas?
>
>  Did you delete your old "backgroundrb" script from script folder of your
>  rails directory? If not please do so, and run rake backgroundrb:setup.
>
>  Also, make sure you have packet-0.1.5 installed.

I found I also had to:

1. Install chronic gem.
2. Add 'require "rubygems"' to new script/backgroundrb

This seemed to fix my issues.

Hope this helps,

John


More information about the Backgroundrb-devel mailing list