[Backgroundrb-devel] Backgroundrb problem in linux

Andrea Morandini andreamorandini at gmail.com
Mon Jul 21 04:13:00 EDT 2008


Hi all,        I am developing a worker which should perform a periodic
task.
Everything is fine when I'm testing it in development mode (mac os x, ruby
1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]) but when I move to
production (ruby 1.8.6 (2008-03-03 patchlevel 114) [i486-linux]) using
"script/bacgroundrb start -e production" the background server log reports
these errors:

/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- log_worker (LoadError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:35:in
`load_worker'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:26:in
`initialize'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:47:in
`new'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:47
from /usr/bin/packet_worker_runner:19:in `load'
from /usr/bin/packet_worker_runner:19
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- backgroundrb (LoadError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from
/var/www/reputation/releases/20080717100533/lib/workers/drb_scraper_worker.rb:2
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:31:in
`load_worker'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:26:in
`initialize'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:47:in
`new'
from /usr/lib/ruby/gems/1.8/gems/packet-0.1.7/bin/packet_worker_runner:47
from /usr/bin/packet_worker_runner:19:in `load'
from /usr/bin/packet_worker_runner:19


The project is versioned and I'm using capistrano.

Any suggestion?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20080721/c09dd02e/attachment.html>


More information about the Backgroundrb-devel mailing list