[Backgroundrb-devel] Fwd: Method hangs for the first time if called synchronously

hemant gethemant at gmail.com
Thu Jul 17 09:44:33 EDT 2008


On Thu, Jul 17, 2008 at 6:01 PM, Martin Honermeyer
<maze at strahlungsfrei.de> wrote:
> Hello guys,
>
> I just installed Backgroundrb (SVN via piston, Packet gem 0.1.7) in my Rails
> 2.1 project. As far as I can tell, I am experiencing exactly the same problem.
> On Linux, that is (Ubuntu 8.04, Kernel 2.6.22-14-xen)!
>
> The first asynchronous worker calls (in console) worked. Then, after restarting
> Backgroundrb and the console, Every synchronous call hangs at the same
> position as told by Jonathan. Asynchronous calls then have no effect either.
>
> Hemant, I tried your patch, but it doesn't change anything for me. I will do
> anything to help ;-/
>

Okay. Can you pastie your worker code and rails/controller code, using
which you are invoking this methods. Also, please paste the code as
you are using. I will see, if I can reproduce this behaviour.

Also, Check the logs. both backgroundrb_debug_11006.log and
backgroundrb_11006.log and if there is any exception there.

Lastly, what exactly you are trying to send from your worker code? You
realize, not everything in ruby can be dumped across wire.


More information about the Backgroundrb-devel mailing list