[Backgroundrb-devel] Backgroundrb 1.0.1: uninitialized constant Packet::ClassHelpers (NameError)

felix clack felixclack at gmail.com
Wed Jan 16 21:47:20 EST 2008


Thanks.

I tried that, however I still get the same error. I'm able to get things
working if I comment out the line
include Packet::ClassHelper.

The problem I experience now is I'm getting Packet::Disconnect errors during
my worker scraping other websites. I'm guessing this problem is not a bug in
backgroundrb but probably with the sites I'm connecting to.

On 17/01/2008, hemant <gethemant at gmail.com> wrote:
>
> Hi,
>
> On Jan 17, 2008 5:03 AM, felix clack <felixclack at gmail.com> wrote:
> > Hi,
> >
> > just updated backgroundrb to release 1.0.1 and am getting this error
> when
> > trying to start backgroundrb.
> > vendor/plugins/backgroundrb/framework/core.rb:18: uninitialized constant
> > Packet::ClassHelpers (NameError)
> >
> > Just updated from r298 where everything was working fine.
> >
> > If I comment out the offending line then backgroundrb starts but I can't
> > connect to it from my app.
> >
> > Anyone have any ideas as to what may be the problem?
>
> Did you remove old backgroundrb script from RAILS_ROOT/script/
> directory? If not remove that file and run:
>
> rake backgroundrb:setup
>
>
>
> --
> Let them talk of their oriental summer climes of everlasting
> conservatories; give me the privilege of making my own summer with my
> own coals.
>
> http://gnufied.org
>



-- 
thanks,
Felix
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20080117/79fe6188/attachment.html 


More information about the Backgroundrb-devel mailing list