[Backgroundrb-devel] Getting started

Richard Everhart rich.everhart at gmail.com
Tue Feb 12 20:49:16 EST 2008


I upgraded ruby right before I wrote my original message and that was
causing some problems.  That's fixed but I still get the 'Not able to
connect' error.  In backgroundrb_server.log there seem to really be
two errors:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load --  (LoadError)
       from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
       from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in
`require'
       from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:342:in
`new_constants_in'
       from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in
`require'
       from /home/reverhart/drb_test/vendor/plugins/backgroundrb/framework/packet_master.rb:113:in
`start_worker'
[...snip...]
/home/reverhart/drb_test/vendor/plugins/backgroundrb/lib/../framework/nbio.rb:24:in
`read_data': Packet::DisconnectError (Packet::DisconnectError)
       from /home/reverhart/drb_test/vendor/plugins/backgroundrb/framework/worker.rb:47:in
`handle_internal_messages'
       from /home/reverhart/drb_test/vendor/plugins/backgroundrb/framework/core.rb:154:in
`start_reactor'
[...snip...]

The first error seems to be due to a ruby and/or rails configuration
error.  However, I've seen this error before, and the '--' in the
error message is usually followed by the name of the file that can't
be loaded.

Thanks for your help!

Rich


More information about the Backgroundrb-devel mailing list