[Backgroundrb-devel] backgroundrb won't start after upgrade

Milo Thurston knirirr at gmail.com
Mon Dec 22 08:47:44 EST 2008


Hello,
I just upgraded BackgroundRb on a working Rails app by checking out
the newest code from the git repository, deleting anything in the
scripts directory left by the old version and running rake:backgroundb
setup. It now appears to be horribly broken and the server won't
start. For example:

bonnacon% script/backgroundrb start
[SNIP]/vendor/plugins/backgroundrb/lib/backgroundrb/bdrb_config.rb:6:in
`parse_cmd_options': uninitialized constant
BackgrounDRb::Config::OptionParser (NameError)
        from script/backgroundrb:15

Adding a "require 'optparse'" instruction to the code mentioned above
leads to this error instead:

bonnacon% script/backgroundrb start
/usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:493:in
`const_missing': uninitialized constant
BackgrounDRb::MasterProxy::BDRB_CONFIG (NameError)
        from /home/milo/Work/Web/cpdnresults/vendor/plugins/backgroundrb/server/lib/master_proxy.rb:7:in
`initialize'
        from script/backgroundrb:42:in `new'
        from script/backgroundrb:42

Is this an error with my Rails setup (2.2.2), or is there something
wrong with BackgroundRb itself?
Thanks,
Milo.

-- 
"One of the greatest delusions in the world is the hope that the evils in this
world are to be cured by legislation." - Thomas B. Reed 1886


More information about the Backgroundrb-devel mailing list