[Backgroundrb-devel] Can backgroundrb work with the rails 2.1.0?

Hao Liu leomayleomay at gmail.com
Sat Aug 23 12:07:02 EDT 2008


Hi, guys,
  bdrb works well with rails 1.2.6, but after I upgrade rails to 2.1.0, 
there seems to be some problems with bdrb and rails.

  I tried to create t a new worker with
    MiddleMan.new_worker(:worker => :alert_worker, :worker_key => 'alerter')
  in my application controller, after tt, I tried to start backgroundrb 
server with
    ./script/backgroundrb start
  in my terminal, but error msg given out, said:

    /home/hliu/Sandbox/blah/trunk/vendor/plugins/backgroundrb/lib/backgroundrb/bdrb_cluster_connection.rb:138:in
    `new_worker': No BackgrounDRb server is found running
    (BackgrounDRb::NoServerAvailable)
        from /home/hliu/Sandbox/blah/trunk/app/controllers/application.rb:8

  Can someone tell me what's going wrong here? Thank you.

  All the best,
  Hao Liu


More information about the Backgroundrb-devel mailing list