[Backgroundrb-devel] Starting It In Production?

Kieran P kieran776 at gmail.com
Fri Aug 15 02:31:35 EDT 2008


Hello,

gnufied pushed a patch earlier today that seems to have fixed this problem
for me.

Do you still get this problem on your local copy if you update to the latest
Git?

Regards
Kieran


On Tue, Aug 12, 2008 at 7:40 PM, Ramon Miguel M. Tayag <
ramon.tayag at gmail.com> wrote:

> Hi everyone!
>
> backgroundrb works fine in my local machine in development mode.  When
> I first tried it out in my VPS in production tho, I ran into some
> problems.  It seems that it keeps looking for the development database
> even if I've explicitly told it to start the production environment.
>
> Here's how I started it, then what my config/backgroundrb.yml file looks
> like:
> http://pastebin.com/m4b7af1b6
>
> I did some searching then saw that this was a problem 2 years ago, but
> was supposedly fixed:
>
> http://rubyforge.org/pipermail/backgroundrb-devel/2006-September/000359.html
>
> What I did for now was put the production database details in
> database.yml under "development" so it's pointing to the same
> database.  When I tried to start backgroundrb this time, I get:
> http://pastebin.com/m4d0084ab
>
> I checked and make sure ~/path/to/app/tmp/pids directory existed
> though.  Does this mean backgroundrb is unable to make its own *.pid
> files?
>
> Thank you for your time,
> --
> Ramon Tayag
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20080815/af0e6ba8/attachment.html>


More information about the Backgroundrb-devel mailing list