[Backgroundrb-devel] Starting It In Production?

hemant gethemant at gmail.com
Tue Aug 12 03:54:32 EDT 2008

On Tue, Aug 12, 2008 at 1:10 PM, Ramon Miguel M. Tayag
<ramon.tayag at gmail.com> wrote:
> Hi everyone!
> backgroundrb works fine in my local machine in development mode.  When
> I first tried it out in my VPS in production tho, I ran into some
> problems.  It seems that it keeps looking for the development database
> even if I've explicitly told it to start the production environment.

Which version of BackgrounDRb? whats the output of?

./script/backgroundrb --version

(preferred version is the git master copy)

You can also try:

./script/backgroundrb --environment=production

> Here's how I started it, then what my config/backgroundrb.yml file looks like:
> http://pastebin.com/m4b7af1b6

No problems here. :)

> I did some searching then saw that this was a problem 2 years ago, but
> was supposedly fixed:
> http://rubyforge.org/pipermail/backgroundrb-devel/2006-September/000359.html

Anything thats two years old should be discarded.

> What I did for now was put the production database details in
> database.yml under "development" so it's pointing to the same
> database.  When I tried to start backgroundrb this time, I get:
> http://pastebin.com/m4d0084ab
> I checked and make sure ~/path/to/app/tmp/pids directory existed
> though.  Does this mean backgroundrb is unable to make its own *.pid
> files?

Check if you have permissons to write to that directory. Usually cap
set symlinks, so as tmp and public are shared between different
deployments. Double check if path is correct.

More information about the Backgroundrb-devel mailing list