[Backgroundrb-devel] Starting It In Production?

Ramon Miguel M. Tayag ramon.tayag at gmail.com
Tue Aug 12 03:40:36 EDT 2008


Hi everyone!

backgroundrb works fine in my local machine in development mode.  When
I first tried it out in my VPS in production tho, I ran into some
problems.  It seems that it keeps looking for the development database
even if I've explicitly told it to start the production environment.

Here's how I started it, then what my config/backgroundrb.yml file looks like:
http://pastebin.com/m4b7af1b6

I did some searching then saw that this was a problem 2 years ago, but
was supposedly fixed:
http://rubyforge.org/pipermail/backgroundrb-devel/2006-September/000359.html

What I did for now was put the production database details in
database.yml under "development" so it's pointing to the same
database.  When I tried to start backgroundrb this time, I get:
http://pastebin.com/m4d0084ab

I checked and make sure ~/path/to/app/tmp/pids directory existed
though.  Does this mean backgroundrb is unable to make its own *.pid
files?

Thank you for your time,
-- 
Ramon Tayag


More information about the Backgroundrb-devel mailing list