[Backgroundrb-devel] backgroundrb script crashing on startup

hemant gethemant at gmail.com
Sun Dec 23 23:49:48 EST 2007


On Dec 24, 2007 9:56 AM, Jason LaPier <jason.lapier at gmail.com> wrote:
> Everything works fine on my development box (Ubuntu 7.10, Ruby 1.8.6)
> but on my server (Fedora Core 6, Ruby 1.8.5) when I run
> script/backgroundrb start, the process fails to start.
> This is with Rails 2.0.2 frozen in the app, and I have the most recent
> version of the plugin (r297). Is Ruby 1.8.6 a requirement for
> backgroundrb now? I can't figure any other reason it would fail...

No it shouldn't be.

>
> backgroundrb_server.log shows:
>
> ==> log/backgroundrb_server.log <==
>
> /usr/lib/ruby/site_ruby/1.8/active_support/dependencies.rb:264:in
> `load_missing_constant': uninitialized constant
> ActionView::Helpers::BasicObject (NameError)
>
>         from /usr/lib/ruby/site_ruby/1.8/active_support/dependencies.rb:453:in
> `const_missing'
>
>         from /var/www/apps/rpg/releases/20071224034514/vendor/rails/actionpack/lib/action_view/helpers/prototype_helper.rb:1068
>
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `gem_original_require'
>
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `require'
>
>         from /usr/lib/ruby/site_ruby/1.8/active_support/dependencies.rb:496:in
> `require'
>
>         from /usr/lib/ruby/site_ruby/1.8/active_support/dependencies.rb:343:in
> `new_constants_in'
>
>         from /usr/lib/ruby/site_ruby/1.8/active_support/dependencies.rb:496:in
> `require'
>
>         from /var/www/apps/rpg/releases/20071224034514/vendor/rails/actionpack/lib/action_view/helpers/javascript_helper.rb:2
>
>          ... 44 levels...
>
>         from /var/www/apps/rpg/releases/20071224034514/vendor/plugins/backgroundrb/server/master_worker.rb:156:in
> `load_rails_env'
>
>         from /var/www/apps/rpg/releases/20071224034514/vendor/plugins/backgroundrb/server/master_worker.rb:143:in
> `initialize'
>
>         from script/backgroundrb:39:in `new'
>
>         from script/backgroundrb:39
>
>
>

I am looking into this now. Can you please sync with latest code and
see if it fixes the issue.


-- 
Let them talk of their oriental summer climes of everlasting
conservatories; give me the privilege of making my own summer with my
own coals.

http://gnufied.org


More information about the Backgroundrb-devel mailing list