[Backgroundrb-devel] Models and Backgroundrb

Charles Brian Quinn me at seebq.com
Thu Jun 22 17:31:53 EDT 2006


Your model that you're trying find on includes some libraries that
backgroundrb doesn't know about.

Try including all of rails when loading the script/backgroundrb/start -- was
just posted by me and someone else recently on how to load ALL of rails
instead of just the ActiveRecord connection.

If that solves your problem, you can either, a) keep it and take the large
memory hit for running backgroundrb with your full RAILS env loaded up, or
b) find out what libraries (the authenticated_system.rb, including
LogineEngine, etc.) that your model that you're performing the Find on is
using, and load those up in your backgroundrb process instead (see archive
for how to do this, too) of the entire environment.

Hope that helps!

On 6/22/06, hemant <gethemant at gmail.com> wrote:
>
> Hi Erza,
>
> I am using login engine in my code...and i get the error "uninitialized
> constant LoginEngine and uninitialized constant LoginEngine", when i try to
> do a find in the worker code!!!
>
> Why am i getting this error?
>
>
>
>
> --
> nothing much to talk
>
> _______________________________________________
> Backgroundrb-devel mailing list
> Backgroundrb-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/backgroundrb-devel
>
>


-- 
Charles Brian Quinn
www.seebq.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20060622/d888d2e5/attachment.html 


More information about the Backgroundrb-devel mailing list