[Backgroundrb-devel] uninitialised constant LoginEngine

hemant gethemant at gmail.com
Fri Aug 25 07:28:34 EDT 2006


In my worker class, when i try to start the worker thread, it throws the
error:

uninitialized constant LoginEngine - (NameError)
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:123:in
`const_missing'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:131:in
`const_missing'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:133:in
`const_missing'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/../../config/../app/models/user.rb:3
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:in
`load'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:56:in
`require_or_load'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:30:in
`depend_on'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:85:in
`require_dependency'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:98:in
`const_missing'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:131:in
`const_missing'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:133:in
`const_missing'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/../../config/../lib/workers/monitor_messageboards_worker.rb:18:in
`do_work'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/../../config/../vendor/plugins/backgroundrb/backgroundrb_rails.rb:35:in
`start_process'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/../../config/../vendor/plugins/backgroundrb/backgroundrb_rails.rb:31:in
`start_process'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/../../config/../vendor/plugins/backgroundrb/backgroundrb.rb:57:in
`new_worker'
/usr/lib/ruby/1.8/thread.rb:135:in `synchronize'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/../../config/../vendor/plugins/backgroundrb/backgroundrb.rb:49:in
`new_worker'
/usr/lib/ruby/1.8/drb/drb.rb:1552:in `perform_without_block'
/usr/lib/ruby/1.8/drb/drb.rb:1512:in `perform'
/usr/lib/ruby/1.8/drb/drb.rb:1586:in `main_loop'
/usr/lib/ruby/1.8/drb/drb.rb:1582:in `main_loop'
/usr/lib/ruby/1.8/drb/drb.rb:1578:in `main_loop'
/usr/lib/ruby/1.8/drb/drb.rb:1427:in `run'
/usr/lib/ruby/1.8/drb/drb.rb:1424:in `run'
/usr/lib/ruby/1.8/drb/drb.rb:1344:in `initialize'
/usr/lib/ruby/1.8/drb/drb.rb:1624:in `start_service'
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/start:96
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/start:92
/home/foo_fighter/public_html/fooapp/config/../script/backgroundrb/start:84

any ideas why? and how to prevent this?

-- 
nothing much to talk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/backgroundrb-devel/attachments/20060825/6feaee72/attachment.html 


More information about the Backgroundrb-devel mailing list