[Alexandria-list] New pango requirements?

Liam Davison liam at liamjdavison.info
Sat Feb 18 08:15:17 EST 2006


On Thu, 2006-01-26 at 21:57 +0000, Liam Davison wrote:
> Hello Laurent et al
> 
> I've upgraded ISPs recently, lost my rubyforge password (for now; i've
> kept backups somewhere) and I've upgraded to a new machine.
> 
> I'd like to document the latest changes to Alexandria - they sound
> really useful. Unfortunately, I can't seem run the latest CVS
> alexandria. What version of Gtk/Pango is required for Alexandria now?
> 
> $alexandria
> -----------------------
> Alexandria just crashed
> -----------------------
> Timestamp: Thu Jan 26 21:50:55 GMT 2006
> Message: uninitialized constant Pango::ELLIPSIZE_END
> Backtrace:
> /usr/local/lib/site_ruby/1.8/alexandria/ui/main_app.rb:555:in
> `setup_books_listv iew'
> /usr/local/lib/site_ruby/1.8/alexandria/ui/main_app.rb:1560:in
> `initialize_ui'
> /usr/local/lib/site_ruby/1.8/alexandria/ui/main_app.rb:133:in
> `initialize'
> /usr/local/lib/site_ruby/1.8/alexandria/ui.rb:48:in `main'
> /usr/local/lib/site_ruby/1.8/alexandria.rb:68:in `main'
> /usr/bin/alexandria:10
> Release: CVS
> Uname -a: Linux battlestar 2.6.12-10-amd64-k8-smp #1 SMP Mon Jan 16
> 17:30:09 UTC  2006 x86_64 GNU/Linux
> 
> I've also noticed a bug in the Ubuntu packaging of libgettext-ruby1.8 on
> AMD64 platforms, as gettext looks for a file
> called /usr/lib/ruby/1.8/gettext/_locale.so , but it's stored
> in /usr/lib/ruby/1.8/amd64-linux/_locale.so . A quick ln -s fixed that,
> but I'm stuck with the Pango error.
> 
Aha, fixed it. It was    a problem with using an older version of
Ruby-Gnome2; my mistake. Now I can look at documenting some of the
recent changes to Alexandria.

Liam




More information about the Alexandria-list mailing list